Jare's Homepage


About Me




Joel On Software
The Old New Thing
The Daily WTF
Sarcastic Gamer
The Escapist
Indie Games
Raph Koster
Amit's Blobs
Lost Garden
Penny Arcade!
The Ludologist
Grumpy Gamer
AI Game Dev
Click Nothing


Digital Gunfire Radio

You are visitor #

according to
(C) Copyright
Javier Arévalo Baeza

Site News

Relinuxed  (Jare)May 12th, 2011 - 12:44
Time for that old laptop to receive Ubuntu 11.04!


Apparently, the graphics card is too old to run the fancy new Unity UI. Ah well, in any case, it's a good idea to have a working Linux machine.

Then, the same problem as before. And I hate myself for not detailing precisely what I did to speed up the HDD. I need to fix this ASAP because the system has started doing massive checks to update packages and the machine is completely unusable. So here it goes this time (DISCLAIMER: I don't really know what I'm doing and I don't care if I destroy the hard drive and its contents):

- See this link for instructions.

- The problem is that I can't do these things on a boot partition while happily running the full system on the Gnome desktop.

- Reboot in recovery mode (keep SHIFT pressed while booting), drop down to the recovery terminal.

- 'mount -no remount,ro /' to remount the file system in read only mode with. Ooops! can't do that while running services that have files open for writing.

- 'fuser -v -m /' lists which services have files open (look for a 'F' or 'f' in the flags) and get ready to kill some of these processes. Note that not all of them will need to be killed, so use some judgement and go one by one. Start with the 'F' ones.

- Try to kill them nicely first with 'stop servicename'. In my case, I just did 'stop rsyslog' and tried to remount, it worked even though there were other services (recovery-menu and root) with 'f' flags. We have a read only filesystem!

- 'tune2fs -o journal_data_writeback /dev/sda1'
- 'tune2fs -O ^has_journal /dev/sda1'
- 'e2fsck -f /dev/sda1'
- 'reboot'

- Upon reboot, I see that the system is now complaining about a missing disk but it then proceeds. Looking at the /etc/fstab file, the missing disk was used as swap during installation.

- In the /etc/fstab file, add the options 'data=writeback,noatime,nodiratime' for your / drive. Reboot.

- Go to the Synaptyc Package Manager to continue updating the system. Mine complained about broken files, and asked me to do 'sudo dpkg --configure -a'. That's all for now!

Well, I dunno what will be different for you.

 JareMay 12th, 2011 - 14:28
Bah, a few minutes after booting the machine, the HDD started its mad spin again and the machine is back to unusable state. I have fixed the swap partition in /etc/fstab by adding the line:

/dev/sda5 none swap sw 0 0

and then run

'sudo swapon -a'

 JareMay 12th, 2011 - 16:47
xfce desktop makes the machine usable.